You are here

Braking noisy on Hoverboards hubs .

3 posts / 0 new
Last post
lurch
Offline
Last seen: 4 days 21 hours ago
VESC Free
Joined: 2021-10-05 18:56
Posts: 33
Braking noisy on Hoverboards hubs .

I have a FSESC4.2 with 2 hoverboards hubs . FOC mode and 12s battery ...  good détection , smooth running ..

 But a growl under heavy braking. I made a log of each vesc. the master (where the receiver of my vx2 is connected) has a strange behavior. from the vertical line, soft braking (no noise) and then hard braking. we see the duty and the motor current that delirious. it is proportional to the braking / regen current. currently at -25 / -20A. I need these values ​​to brake properly. An idea ?

Previously on a Lingyitek esc, these hubs did not brake much, but did not growl. on vesc they brake very well. but it makes noise.

2 logs are different short runs . I can't log the 2 vesc together with my uart BT module .

Here the Master :

brakemaster.PNG

 

and the slave :

brakeslave.PNG

 my motor parameters  :

141mOhms

299uH

18mWb

KP 0,3

KI 141

observer gain 2,9

Kv 18~20

on this video,braking at 3 and 8s.

lurch
Offline
Last seen: 4 days 21 hours ago
VESC Free
Joined: 2021-10-05 18:56
Posts: 33

another log ..

 vertical line is the start breaking .

in fact he problem is mainly on slave ESC .but visible on master too.

 you see positive current motor spikes while braking ,  battery current negative and crazy duty spikes ? 

 don't understand ..

 

master :

brakemaster2.PNG

and slave :

brakeslave2.PNG

lurch
Offline
Last seen: 4 days 21 hours ago
VESC Free
Joined: 2021-10-05 18:56
Posts: 33

same noise with others hoverboard hubs . same Kv but more windings and bigger magnets ..